Shibboleth Common - Java
  1. Shibboleth Common - Java
  2. SC-113

BaseAttribute.getEncoders returns an untyped List

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Invalid
    • Affects Version/s: 1.1.4
    • Fix Version/s: None
    • Component/s: Attribute Authority
    • Labels:
      None
    • Java Version:
      Sun 1.5
    • Servlet Container:
      Jetty 7

      Description

      Most of the APIs use generic typed containers when they return collections, but the list of encoders isn't typed.

        Activity

        Chad La Joie added a comment -
        I'm not sure what you mean. The return type is List<AttributeEncoder>. Is your concern that the AttributeEncoder doesn't specifically state AttributeEncoder<?>
        Scott Cantor added a comment -
        Hmm, I don't know what I meant either. I could have sworn the return type was just List, and the plugin I wrote definitely used that (and I wouldn't have done that by design). Perhaps Eclipse fouled me up in some way. I'll close.

          People

          • Assignee:
            Chad La Joie
            Reporter:
            Scott Cantor
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: